The place for technical discussions about GA and flying.
Forum rules: Technical discussions about GA only, please.
#1733732
I placed a similar thread with the same title last year. As a result i had both GPS antennas removed, with one requiring replacement. Both needed earthed back to the chassis; which was cleaned up, conducting grease applied and refitted. the cables weren't changed. This seemed to do the trick for a few months.

Both GPS systems have separate antenna and cabling between the units and antennae.

The problem has returned. Some flights both GNS430W and a GPS150XL both drop out of signal: together!

Just like the dentist; when I drop the aircraft off for a 100hr, both units are functioning perfectly well. However the fact that they both have separate antennae, they either function or don't simultaneously, i'm beginning to think that there could be something else on the aircraft that interferes with the GPS signal that causes the signal block. The cables haven't been changed when the antenna works were undertaken last year, avionics chap doesn't think this is an issue due to the fact they both fail together.

The CAMO and avionics installer are with the aircraft for the next couple of days but an intermittent fault of this nature could prove pretty £laborious thus any pointer once again, appreciated.

thanks
#1733739
Thanks for the response. However there seems to be no rhyme or reason to failure. Last three short flights have functioned perfectly well and the drop out and return to service can be for a full two hour flight or a five minute loss of signal.
Nothing changes and the signal returns.

If there is a pattern I’ve not recognised it as yet. Could the strobes, transponder, comms be causing this? None of that has changed in the last two years.

A previous reply did want to focus on cables, but since they’re separate the avionics chap won’t look there at present, but did test them last year and they were all good.
#1733762
As it's a common simultaneous failure, I'd be looking for a supply, earth (return) or aerial/cable fault.


Both co-axial signal- cables getting pinched/pulled at a particular point, perhaps? feed/return issues can be caused by oxidation/corrosion, leading to high-resistance/heating/arcing (which "cleans" the conductive path) and then the cycle repeats until there's a total failure or a goodly bit of burning.

I am not an airframe mechanic/electrician, the suggestions are worth what you paid for them. :D
#1733776
Just to say - an intermittent signal loss on certified equipment will stop them showing GPS for at least 5 minutes until they are satisfied that the signal is good again.

GPS signals are very weak, so EM interference can block them quite easily. Also I think I read that the garmin antenna ground is connected to the aircraft chassis so other items could affect it.

Do you have static dischargers?
#1733911
Static Dischargers? I do have an electrical background and i'm comfortable with the theory on what where and why these systems could be failing. I don't know what static dischargers are though. :?: (A high resistance earth/ground route between parts of the aircraft?)

The avionics chap is looking for possible alternatives before he replaces the cables, as apparently this is a bit of a task.
#1733999
Do you have perhaps a noisy motorised rotating beacon producing a large RF noise floor. Or perhaps an electrically noisy fuel pump, or standby electric motorised vac pump, noisy LED wing tip lights etc etc.

It could really do with an off air spectrum analyser to investigate the RF environment in the aircraft with various items on/off since you gave already addressed aerial etc and it is affecting both systems at the same time.
#1734133
Great stuff guys, i'm a wiser man now. Yes I do have static dischargers: thanks.

Radios are GNS 430W and a new (January 2019) Garmin GNC255A (a great unit i'm only slightly using to capacity)
Aircraft is covered but left outside, no rotating beacons: the strobes aren't LED older zenon tube style (which I can actually hear through my radio transmissions): so i know the strobes are 'noisy' in RF terms: I've even had ATC mention it!

The interference issue will be addressed by the RF specialist and I'll ask the avionics guy to look into that too. Will report back if all clear received.

thanks so far, looks like the cables wont's go wrong being replaced.
#1734654
Advised the camo of some of these items and he has changed strobe power supply unit. No interference on the radios and tonight gps was working fine. Time will tell in This respect.
Good part is that the strobes now give a more modern three rapid flash rate as opposed to the single flash previously. Christmas came early for me :)
I hope this is the end of the matter and also hope this closes the thread as I do intend to get a few flights in during the holidays. :thumright:
T67M liked this