For help, advice and discussion about stuff not related to aviation. Play nice: no religion, no politics and no axe grinding please.
By Colonel Panic
I am finding that I get more and more error messages when following a Youtube link.

An error occurred. Please try again later. (Playback ID: 9Dda9fZJWMVgYtos)
Learn More

The Learn More bit doesn't help, and my internet speeds are fine (28 down, 8 up). This only happens if I follow a link - never if I open Youtube and then click on one of their links.

Any suggestions as to the cause? TIA

PS In case it helps, herewith a link that doesn't work for me.

PPS Hmmm, the video runs fine within the Flyer Forum, but not if I try to watch it within YouTube.

User avatar
By Flyin'Dutch'
That is a serious beard! Something to aspire to? :D
Colonel Panic liked this
By Colonel Panic
stevelup wrote:It'll be your PiHole probably... Override the DNS and see if the problem goes away.

Disabling Pi-Hole (for 5 minutes) doesn't resolve the issue. Not quite sure what is meant by overriding the DNS. Sorry. :pale:
User avatar
By stevelup
Just set your computer to natively use some other DNS instead of pointing it at your PiHole.

Network > Advanced > DNS > put in
By Colonel Panic
Thanks; sorry for being dim. Disabled Pi-Hole for another 5 mins, changed iMac DNS to, rebooted Mac and then tried YT again. No change (other than a marginally different Error Code.

An error occurred. Please try again later. (Playback ID: 61Fsy8gwtb9-fbrz)
Learn More
By Colonel Panic
stevelup wrote:Any ad-blockers running in-browser?

Nope; I disabled all of them when I started to use Pi-Hole.

Interestingly, on my MacBook Pro in the house, with Pi-Hole running and SysPref/Network using Pi-Hole for DNS, I can see that advert in YouTube. So, either the change of day, the wire going up to my office (separate building), or my iMac that was the cause. Will try my iMac later.

EDITED TO ADD: Hmm, working in my office / iMac today. Maybe it is a YouTube Thing, rather than a Me Thing.