The place for technical discussions about GA and flying.
Forum rules: Technical discussions about GA only, please.
User avatar
By Charles Hunt
#1688770
I understand that one should only put the clamp around one of the conductors, but am perplexed that I get significantly different readings depending on whether I clamp the +ve or -ve lead.

Surely current around a circuit is constant.

Am I missing something?
User avatar
By Charles Hunt
#1688821
Not aware of a zeroing function. Haven’t got it with me at the moment.

Not aware of a knurled knob on the side, is there a standard method of zeroing these modern digital things?
By Nomad63
#1689098
Also, when you zero it make sure you do so with the meter as close to the position it will be when you actually clamp around the wire.
In my experience the zero calibration varies as you move them around close to other wiring, which could explain the difference in the +ve _ve wires if you are not calibrating zero when close to the measuring position.
User avatar
By Charles Hunt
#1689128
Gave it a quick go yesterday and trying to get a steady zero and then get it over a wire half way down the fuselage gave meaningless results.

Current can’t flow if there’s infinite resistance so maybe a simple resistance check will show if there really is a drain problem. New master switch fitted.
By Lerk
#1689222
Current around a series circuit is constant as you say, which may mean that what you are measuring on the -ve is one leg of a parallel circuit. Ie some of the -ve is going back through the body.