Page 1 of 1

Garmin 430 Squelch issue

PostPosted:Tue Mar 19, 2019 1:02 pm
by Baldrick
Hi, We’ve recently had a problem with a noisy squelch on our 430 which seems to have occurred since changing to 8.33 MHz separation.
It’s definitely the Garmin as the rx illuminates when the squelch breaks.
Has anyone else experienced a similar problem and if so how did you fix it?

Thanks,

Baldrick

Re: Garmin 430 Squelch issue

PostPosted:Tue Mar 19, 2019 1:09 pm
by T67M
What sort of squelch issue? Not lifting at all? Not lifting quickly enough? Not squelching at all? Not squelching quickly enough? Something else?

I've certainly noticed that a large number of aircraft and ground stations now "fade in" over a couple of seconds at the beginning of a transmission rather than starting cleanly since we moved to 8.33, ie the squelch is lifting too slowly. I now consciously wait a second after pressing the button to compensate.

Re: Garmin 430 Squelch issue

PostPosted:Tue Mar 19, 2019 1:41 pm
by Baldrick
The squelch is breaking almost continuously without any audiable transmission being received.

Re: Garmin 430 Squelch issue

PostPosted:Tue Mar 19, 2019 5:29 pm
by T67M
Almost continuously implies the squelch setting (SQ833 and/or SQ250) in the setup menu needs adjusting slightly - see page 5-15 of the installation manual.

Absolutely continuously implies that the volume knob has been "clicked", which lifts the squelch until the knob is clicked again.

Re: Garmin 430 Squelch issue

PostPosted:Tue Mar 19, 2019 5:47 pm
by Paul_Sengupta
Or there's interference, local or otherwise.

Re: Garmin 430 Squelch issue

PostPosted:Tue Mar 19, 2019 5:56 pm
by Baldrick
Thanks T67M,

I came to the same conclusion, but I can’t get to the aircraft again until Friday.
Also a bit wary of going into the setup menu, but as they say faint heart never won a pig.

Thanks shay,

Baldrick.

Re: Garmin 430 Squelch issue

PostPosted:Mon Mar 25, 2019 9:45 am
by Baldrick
T67M wrote:Almost continuously implies the squelch setting (SQ833 and/or SQ250) in the setup menu needs adjusting slightly - see page 5-15 of the installation manual.

Absolutely continuously implies that the volume knob has been "clicked", which lifts the squelch until the knob is clicked again.


All combinations of avionics ave been tried to eliminate the problem to no avail, so I accessed the Com Setup page, the SQ250 was set to 43 and the SQ833 was set to 14.

Twice I adjusted the SQ833 but was unable to store the changes. The ‘Store Calibration’ field could not be selected.

The next option is to send the box off for repair the quote for which was £1100. Unless anyone knows how to store the setting?

Re: Garmin 430 Squelch issue

PostPosted:Mon Mar 25, 2019 9:51 am
by johnm
@baldrick have you asked Alec Vincent at RGV for advice, if not I would recommend that you do.

Re: Garmin 430 Squelch issue

PostPosted:Mon Mar 25, 2019 10:18 am
by Baldrick
Thanks for that I’ll give him a call.

Re: Garmin 430 Squelch issue

PostPosted:Sat Mar 30, 2019 4:59 pm
by stevelup
Have you eliminated every possible rogue source of RF noise in the aircraft? Very specifically made sure there are no USB chargers are similar left plugged in? Tried it with absolutely every other device turned off except the GNS?

Re: Garmin 430 Squelch issue

PostPosted:Sat Mar 30, 2019 5:57 pm
by Baldrick
After a chat with Alec Vincent at RGV I was able to adjust the 8.33 MHz squelch setting. This got rid of the noise, however when I switched the landing lamp on the noise reappeared. We fitted an LED replacement lamp nearly 2 years ago and the squelch problem has only recently occurred. I’ll bench test it next week it’s a Teledyne Alphabeam. I’ve emailed the manufacturer, but unsurprisingly they haven’t replied.

Re: Garmin 430 Squelch issue

PostPosted:Sat Mar 30, 2019 6:10 pm
by stevelup
It’s almost certainly a switch mode power supply somewhere, and there will indeed be one in your LED landing light.

Could be a ground issue as well - the landing light may be within spec.

Re: Garmin 430 Squelch issue

PostPosted:Sat Mar 30, 2019 6:25 pm
by Baldrick
Thanks, hopefully it’s as simple as a poor earth.

Re: Garmin 430 Squelch issue

PostPosted:Sat Mar 30, 2019 7:03 pm
by T67M
The squelch level should really be adjusted with every other device switched on. If you set it with the landing light off, you may not have set it to a high enough value.