The place for technical discussions about GA and flying.
Forum rules: Technical discussions about GA only, please.
#1644877
I have a GNS430W and an older Garmin GPS unit and it's becoming more frequent and for longer periods when i lose the GPS signal. I have a back up hand held unit and that confirms that GPS source (as well as skydemon) is still active. I'm now convinced it's the antenna or something associated, as both fitted GPS drop out together, for no apparent reason. They rarely come back on during flight and require on/off to 'reboot' despite the fact they are both continually scanning and gathering location data etc.

Is this likely to be a loose connection/bad wire or can the antenna give up the ghost and if the latter how can this be proven, especially if its intermittent failures? I think i'm about to enter into a process of elimination with this, but any steer would be appreciated. PA28 Archer II. I'm curious to know if there are known antenna/receiver issues, or shall i just go looking. (or await the annual)

thanks
#1644885
IIRC the GPS aerials are active units so no doubt they can malfunction, another common problems with aerials is the loss of the ground/mass connection if there is corrosion between the skin of the jalopy and the base of the aerial.

HTH.
#1644886
How are the two unit's GPS antenna connected? One device could be a slave of the other, but normally they would be separate (antenna etc). The 430W anyway should have a separate external antenna. Strange they are both failing at the same time.
I assume that they aren't dropping out in the same location each time? There are various places with jamming being trialled, or HIRTAs and as GPS signals are very weak it is fairly easily disrupted.
#1644893
The GNS 430W needs to have correct antenna and cable as I recall, there were some issues where people swapped a 430 for 430W and didn't replace the antenna and cable. The older one needs to be completely separate and corrosion is a bad thing.

I seem to recall that radio interference on certain frequencies was an issue too, worth a bit of searching possibly?
#1644981
Thanks guys. I have the original receipt for the GNS430W being fitted, in with the log books etc. Bournemouth Avionics fitted it in 2009/10. The previous owner spent a few quid at the time and the installation was all as per OEM instructions according to the modification instruction, including a new GPS antenna.

The roof installation looks 'fine' from the outside and the roof lining looks like it was installed yesterday. The four screws that hold the unit in place i believe will need removal of the part of the headlining to get to the underside. The fact that its only 9(max) years old, I'd have thought the equipment would have lasted longer.

Both GPS units lose signal together. The first time it happened, I discussed it in the clubhouse, i was advised that the 'services' sometime block navigation in my flying area, but yesterday was 70% no signal and tonight was 100% loss. Which it's a handy tool for night flying too, as much as i'm becoming increasingly reliant upon skydemon, i do want to get these units fully functional again. It's taken me 9 years to fix heater setting 1 on my Mk1 golf (last weekend) and I'll not be letting this go past its ARC. Time to tinker and I'll speak with the local Garmin rep and see if they sell many antennas separately.
#1645064
Garmin did a batch of antennas that went bad - from memory I have a feeling they were GA56's. If the antenna has gone bad, it won't get better itself and replacement is the only option - you might be able to get some assistance from Garmin though depending on the serial number.

One test you can *try* - when the 430W loses the signal, put your handheld near the antenna - if the handheld drops out too it is definitely the Garmin antenna gone bad (it re-radiates garbage)
#1647706
I had the same problem caused by loss of signal.Changed the active aerial and had some new super low loss coax fitted. Completely fixed the problem. The 430W latches on to a lot of satellites and needs the strongest signal possible as the sat power outputs a re pretty low,
#1671505
thanks for the input guys. first flight yesterday since december 100hr/Annual. new antenna fitted and the cable tested out fine so avionics tech didn't bother changing the cable, turns out the electrical bonding to the aircraft skin was non existent at the antenna. no issues with the GPS yesterday and i'm confident the avionics chap sorted it.