The place for technical discussions about GA and flying.
Forum rules: Technical discussions about GA only, please.
By MikeW
#1732933
The unit works fine with external power or a charged battery, but it will not charge the battery. It's not the battery (genuine Garmin BTW), this charges OK in another 296.

Any ideas please anyone? Is there possibly an internal fuse in the charging circuit?

Thanks.
User avatar
By PaulB
#1732940
There's a video on YouTube that says that the battery contains circuitry that controls the charging, but this needs battery power so when the battery is completely flat you can't charge it.

The chap demonstrated taking the battery apart and connecting to a 9V normal battery to charge it enough to power the circuit meaning the charger would work again.

My 296 battery is in the same condition and it looked a bit of a faff to fix it and I may one day pay Harry M for a replacement.....

Someone like Paul S will post a link to the video imminently! :-)
#1732957
Not at the moment, I have to go out and help someone unload an aeroplane kit! :D

The battery charges ok on another 296 though, so it's probably not that. Is there a setting for rechargeable or AA pack somewhere which may be set to AA pack?

Right, got to run, can't look up anything right now!
User avatar
By Rob L
#1733295
I have a 496 (the colour one) for sale (an Estate sale) that needs an update and new batteries, but otherwise works just fine. Comes with remote speaker, weighted beanbag, all cables, manual, bag etc.

All proceeds to MNDA

New batteries are still readily available.

Offers? Anything considered.
#1734566
One thing with that video, I wouldn't epoxy the battery back together personally, as you might want to do the same thing again! :-) As mentioned in another thread, I did a similar thing with my VXA-700 radio battery, but rather than using a 9V PP3, I actually connected each cell in turn to a USB lithium battery charger, this sort of thing.
By Boxkite
#1734583
Paul_Sengupta wrote:One thing with that video, I wouldn't epoxy the battery back together personally, as you might want to do the same thing again! :-)

Yes, I would have at least taped it up and tried it in the charger first :D