The place for technical discussions about GA and flying.
Forum rules: Technical discussions about GA only, please.
#1688399
I've just received my Sky Echo 2 and have tried using it with Sky Demon on my 4G Sim card equipped Galaxy Tab A tablet. I've set it up correctly and it connects to the tablet via its inbuilt wifi. The problem I then have is the tablet cannot receive data (weather, extra airfield plates or whatever) via it's sim card as it thinks it has a wifi connection. I then get continual red error messages on sky demon saying "There was an error while trying to communicate with the sky demon server. Sky Demon has now switched into offline mode so that further errors will not appear. When you connection has been restored you can switch back out of offline mode" .
I get this message about every two minutes. Ideally I would like data enabled but if I can't get that I would very much like the warning messages turned off!. Any help gratefully appreciated......
#1688423
Sky Demon setting: Settings -> Internet Settings ->
Then choose either:

Offline Mode or
Live Data when Planning

Be sure not to select: Live Data when Planning and Flying.

You shouldn't use data while flying anyway, so Live Data when Planning should be sufficient. When you go into flying mode, you'll no longer need the data so can connect to the Sky Echo.
#1688500
Hi Paul

Thanks for the response. I eventually worked out how to stop it happening but what I was wondering was if there was any way to still be able to receive data. It's useful if you need to look something up or check latest weather when enroute.

Cheers

NB
#1688509
Useful but illegal and could result in you being banned from the mobile network...

However, PilotAware try and get round this issue by setting certain fields in their Wifi hotspot which means the tablet knows it's not connected to the internet, and thus it'll still use the built in sim card. I think the behaviour varies from tablet to tablet though on how it deals with the "flag" which says "no internet here".