Primarily for general aviation discussion, but other aviation topics are also welcome.
By thegasguy
#1827584
Yes, I'm aware that Uavionix tech help is great ( I've spoken once already to Chad, about another matter) - but there must be a lot of new practical experience on here judging from the numbers going out the door at the retailers.
So here goes; I've set up my new Skyecho ( via my iPhone, which is my backup nav when flying).
All good apart from when clicking 'go flying' a message pops up saying that my aircraft needs to have its hex code and call sign set up.

Then, I am offered the choice of updating these details.
On choosing to do this, I see that they are actually there.
Nevertheless I re- enter them and save -but- it does not resolve the issue, as next time it's the same.

Not a disaster as everything else seems to work.
No aeroplanes to be seen, but - there aren't any I guess.

Now, the issue. I use an iPad mini for main nav and I can't get the 'main page' setup page to 'save' - there is no green tick. It is ok on the phone but not on iPad.
This means I can't turn the ADS-b off using the iPad, or use it in a different aircraft.
Also the 'your aircraft is not configured ' issue is the same on the iPad as the phone.
The hex code and call sign are actually there, but Skydemon won't see them as there on loading on iPad.
Factory re-set option does zero.

It's all a bit arcane and I'm only just keeping a grip on the jargon, but if it helps : the software is up to date, the wifi hotspot works fine and I have RTFM about 10 times.

Anomalies are:
No option for Europe and Australia as manual claims.
The downloaded software updates included 'coredump' which is not mentioned, and sounds scary.
The boxes for my aircraft fill, but won't save on iPad- but will on iPhone; zero effect in reality.
iPhone has offset for width options but iPad doesn't have anything in the drop down list.

Phew! Quite a lot.
Any thoughts anyone.
User avatar
By Tim Dawson
#1827588
This sounds like something we were talking about in the office this afternoon. I reckon it’s your aircraft profile in SkyDemon (nothing to do with your SkyEcho) that is missing its hex code, and that’s why you’re seeing the warning.
gaznav liked this
By thegasguy
#1827636
Thanks for that Tim;
Oddly the hex code was already in skydemon when the message popped up the first time as a sky echo configuration box , although I hadn't put it there.
It must have come over from the Skyecho- I never knew it before.

The callsign was there as well - no gap after G, as per input into Skyecho setup.
Of course SD 'knew' it already, but not in that format.

I tried putting the gap in, in case that was it - but no joy.

I also tried clearing the boxes and re - entering the data and saving. No go.

The 'pop up' box looks slightly different to the SD menu box that does the same thing - relevant?

My aircraft in SD is the third iteration, I've never found out how to delete the first couple of attempts- it calls it aircraft 3 , or something similar.
By johnm
#1827698
My aircraft in SD is the third iteration, I've never found out how to delete the first couple of attempts- it calls it aircraft 3 , or something similar.


That may be the problem. How to delete depends a bit on which device you are running on and once deleted you need to sync with cloud.