Primarily for general aviation discussion, but other aviation topics are also welcome.
#1808516
mlawton wrote:I've got the sky echo but can't register for a portal! It won't accept my user name to proceed, tried at least 10 various user names, 3 different browsers, deleted cookies ,disabled ad locker and all firewalls,tried 3 different computers. Phoned CAA a couple of times said they would pass on toIT dept. Heard nothing for 3 weeks! Spent at least 5 hours trying! Any one else having problems?


Infringe and they'll send you a signup :D
Artschool liked this
User avatar
By mick w
#1808527
mlawton wrote:I've got the sky echo but can't register for a portal! It won't accept my user name to proceed, tried at least 10 various user names, 3 different browsers, deleted cookies ,disabled ad locker and all firewalls,tried 3 different computers. Phoned CAA a couple of times said they would pass on toIT dept. Heard nothing for 3 weeks! Spent at least 5 hours trying! Any one else having problems?


Same here , they are supposed to be getting backto me ...... :roll:
By Lefty
#1808530
I signed up for the portal. After 10 days got an email saying they couldn’t read the scan of my “proof of residence” document I had submitted. Seems their portal is prone to corrupting documents. They asked me to re-send via email - not via 5he portal.

Strange thing, is that I had sent them a copy of my PPL, with my CAA ref number and home address on it. In response to their email, I have now sent them a local rates bill. However I can’t understand why they need me to re-prove my address. I’ve held a UK PPL continuously since 1972 - and I’ve been at the same address for almost 30 years. If they’ve had my current address on file for 30 years, what’s the point in making such a big fuss about asking me for It again?

Now been 5 days since I emailed the replacement proof of address, I’m not expecting to hear anytime soon. :?

Stop - press. Just checked my emails - and the CAA have validated my credentials and allowed me access to the portal. Now to apply .......
#1808562
Lefty wrote:
Strange thing, is that I had sent them a copy of my PPL, with my CAA ref number and home address on it. In response to their email, I have now sent them a local rates bill. However I can’t understand why they need me to re-prove my address. I’ve held a UK PPL continuously since 1972 - and I’ve been at the same address for almost 30 years. If they’ve had my current address on file for 30 years, what’s the point in making such a big fuss about asking me for It again?

Perhaps it is run by the person who remembers the thousands of Clued Up magazines that bounced back the first time they sent them out to licence addresses
@Cessna571 how long? (sorry if you said previously)
User avatar
By tnowak
#1808563
It took about 10 days for my identity to be verified (after documents submitted). I submitted my claim a few days later, but no money in the bank so far. I think I read somewhere on the CAA website it can take up to 6 weeks to receive the rebate.
#1808576
@Irv Lee
About a week to verify me and let me click the claim link, then I claimed, about a week to accept the claim, then got an email saying you’ll get your money in 1 to 2 weeks.

Then got an email saying you’ve been paid.

I just sort of had to “leave them to it” as it wasn’t very clear what was going on for the first couple of steps, it was kind of like

“Well... what now? Have I done it or not? Any confirmation? Nope? I’ll wait a bit and see”

Helped that my life is crazy busy elsewhere at the minute, so I didn’t even think about it between the emails.
#1808628
mlawton

I had almost identical problems and two I.T. savvy friends couldn't solve them. One managed to create a new portal account on his ipad at home, with yet another different username and password combination (but with my details) and my claim went through that route.

Still waiting for payment.

I think perhaps their system had a problem with either my email or the three different IP addresses that I tried.