Primarily for general aviation discussion, but other aviation topics are also welcome.
User avatar
By UpThere
#1654891
There's a problem when I plan a route on my iPad and don't shut down SkyDemon, before putting the iPad in my flight bag for the 20 mile drive to the airport. When I mount it in the aircraft and click Go Flying, it starts searching for my location, but never finds it. The workaround is to restart SkyDemon. Has anybody else had this problem?
User avatar
By PaulB
#1654893
Can't say I have, but then again, I usually review my route when I get to the flying club.
#1654980
Rob L wrote:As a quick fix, can I suggest you shut down SD until you get to the airfield? :roll:

Gosh! Why didn't I think of that? It's a humble pleasure to share this forum with such a clear thinker!

Of course, if there is a bug and nobody reports it, what are the chances it'll get fixed?
Rob L liked this
#1654982
As an aside, there are SkyDemon support forums and this isn't (officially) one of them. :D

Lots of people will help here, but it isn't really suitable for submitting a formal bug report.
idlelayabout, PaulSS liked this
#1654992
Very sorry to have tried to be helpful by providing you with advice as to where you might find definitive information.

I wish you all the best in solving your problem (which I have not experienced on other tablets, FYI).
RisePilot, G-BLEW, UpThere and 3 others liked this
#1654999
UpThere wrote:There's a problem when I plan a route on my iPad and don't shut down SkyDemon, before putting the iPad in my flight bag for the 20 mile drive to the airport. When I mount it in the aircraft and click Go Flying, it starts searching for my location, but never finds it. The workaround is to restart SkyDemon. Has anybody else had this problem?


That is seriously odd.

Never had anything like that on iPhone or iPad.

Does the same happen when you use other nav apps (such as google maps or apple maps)?
#1655001
I save my planned route to the iPad then shut it down .

On arrival to fly it’s there in the iPad but also in the memory as back up .

Of course saving it to the cloud is no ’kin use as there’s no internet at the strip :roll:

Ive never had your specific problem it certainly sounds like you have a bug .

Last question is it a long way from your home to your aeroplane ?

Peter
Last edited by PeteSpencer on Sun Dec 02, 2018 8:59 pm, edited 1 time in total.
#1655024
I was having very similar symptoms earlier this year on earlier versions of Skydemon and IOS under essentially the same circumstances. In my case however the Go Flying button would grey out and when pressed would crash Skydemon.

Having reported the issue to Skydemon and sending them the crash logs I got a response back to suggest it was IOS at fault and related to IOS not delivering a GPS fix to the app. A few days later IOS 12 was released and I haven’t seen the issue again since.

It’s worthwhile saving the crash logs and sending them to Skydemon.
#1655055
IOS version is now 12.1, but I haven't tried it since 12.0. SkyDemon is the latest release. I only use the iPad for SkyDemon, so don't know if other mapping apps have the same problem. Anyway, they may continue running in the background when the iPad's in its carry case.

My aircraft's been away for its annual for the past month, but I hope to get it back any day now so I can check if the problem can still be reproduced.