Primarily for general aviation discussion, but other aviation topics are also welcome.
  • 1
  • 10
  • 11
  • 12
  • 13
  • 14
  • 29
#1655923
I run a pretty ancient Iphone 4 that I have replaced both the screen and the battery on, and which I originally bought second hand. It will be in use until it no longer fits my needs, or it needs a fix that I'm not capable of performing myself. Just because modern electronics are reckoned by the majority to be disposable, it doesn't mean they have to be.
cockney steve liked this
#1658904
Hi all, I am more than happy to pay the £30 on top for FLARM decoded in SD as I think glider traffic is a big issue, not easy to see and difficult for radar traffic service to report reliably as well (no height).

So I recently bought the Sky Echo 2 to use with SkyDemon- but when I air tested the combo proved unreliable due to a) disconnections between SD and SE2, coupled with another symptom 2) SE2 under-reporting ground speed eg showing 30kts when barrelling along @ 125kts GS.

uAvionix support is very responsive so far and have promised a software fix for the GS issue. They say that the disconnects are a “collaborative issue” between them and SkyDemon and don’t happen with other EFBs, so I’ve also written to SkyDemon to ask if they can help and are planning a fix on their side?

Interested to hear if others have seen the same - and if anyone out there is using SE2 with a different EFB to confirm that the problem doesn’t occur when not using SkyDemon..?

At this stage though I’ve spent nearly £500 all up and it’s not usable in flight (works great in the car at lower ground speeds less than 90kts..!)..!! :(

No doubt they’ll fix these early issues sometime soon and before the weather starts to improve - and the traffic increases ..!
Last edited by Aussie Andy on Wed Dec 19, 2018 8:19 am, edited 1 time in total.
Flyin'Dutch' liked this
#1658907
Hi Andy, the groundspeed, and consequently plog, issue is common across a number of apps (I have it on ForeFlight). I understand a software fix is imminent. I'm not seeing any connection dropouts with FF.
User avatar
By gaznav
#1659097
No issues at all with my SE1. The first SE2 that I had which was pre-production worked a treat. The second SE2 did drop out until they sent me a software patch within 2 days of noticing the issue and then I’ve not seen an issue since.

I’ve never seen an issue with groundspeed with the SE1, the pre-prod SE2 or the current production version SE2.
By cecilthecat
#1659572
Please can someone with the download links for the firmware update for the SE2 put them up here as I am also seeing the WiFi dropping issue ?

Not sure why uAvionix don't put this up on their support pages which would make sense ??
User avatar
By gaznav
#1659585
Aussie Andy wrote:Gaz, are you using yours with SkyDemon or a different EFB..?


Andy, I use SkyDemon. When I downloaded the SkyDemon beta-test software to use FLARM then I followed their instructions to email Trent at uAvionix and he sent me a zip file with the updated software for the SkyEcho.

Attached is a zip file that contains the two files of software necessary to enable FLARM.

The updates are done from the 192.168.4.1 web page while being connected to the device. The first one is a WIFI update. The file to upload for this update is SkyEcho_V0.2.5.bin. Do not power down the device or close out of the web browser while updating is taking place. Once the update is complete, power cycle to device and update the ADS-B software. The file to upload for this update is PingTransceiver_SE2_v2_6_0.uav. Again, do not power down the device or close out of the web browser while updating is taking place. Power cycle once more and you should be good to go. Let me know if you have any questions.


I haven’t seen any issues since. Have you got the same software loads? If not drop the company an email.

Best, Gaz
  • 1
  • 10
  • 11
  • 12
  • 13
  • 14
  • 29